Dwie funkcje wystarczą! Prosty sposób na druk kalkulowany.

exel

Druk kalkulowany, który oferujemy jako alternatywę dla produktów wariantowych zyskuje coraz większą popularność wśród osób korzystających z iwarePRINT. Nie ma się zresztą, co dziwić, bo daje on wiele swobody i elastyczności w modyfikacji cen.

O zaletach druku kalkulowanego rozpisywał się Sebastian. Ja natomiast chciałbym pokazać, że nie trzeba być mistrzem pakietów biurowych, by w pełni korzystać z tego rozwiązania. Co więcej, do stworzenia kalkulatora dla praktycznie każdego produktu, wystarczy znajomość zaledwie dwóch funkcji!

JEŻELI

Pierwsza z nich to prosta funkcja logiczna “JEŻELI”. Sprawdza ona warunek (test) logiczny, np. czy 1 jest większe od 0 ( 1>0). Jeśli wynik jest prawdą, to wyświetla zdefiniowaną wartość, a jeśli jest nieprawdą, to wyświetla inną zdefiniowaną wartość.

Składnia:

=JEŻELI(Test; Wtedy_wartość; W_przeciwnym_razie_wartość)

wybór parametrów

Przykładem zastosowania funkcji JEŻELI może być wyświetlanie wybranego przez klienta terminu realizacji, przez sprawdzenie, jaka wartość parametru znalazła się w komórce C8:

=JEŻELI(C8="24h";1;3)

Jeśli będzie to “24h”, to zwróconą wartością będzie 1. W każdym innym przypadku, wyświetli się wartość 3.

Ten sposób jest jednak mało praktyczny, bo sprawdzi się tylko, gdy parametr będzie posiadał dwie wartości. Sama funkcja przyda się nam jednak, za chwilę, do czegoś innego.

Co zrobić, gdy wartości jest więcej? Wtedy najlepiej dane umieścić w tabeli (matrycy):

tabelka z excela

Dzięki temu łatwiej w przyszłości będzie rozbudować kalkulator o nowe opcje, gdy pojawią się, na przykład, inne terminy realizacji.

Tutaj wkracza druga funkcja:

WYSZUKAJ.PIONOWO

Pozwala ona przeszukiwać pierwszą kolumnę matrycy pod kątem danej wartości, np. nazwy parametru, i zwracać wartość z kolumn po prawej stronie od niej.

Składnia:

=WYSZUKAJ.PIONOWO(kryterium_wyszukiwana;macierz;indeks;kolejność_sortowania)

Przykładowo, taki zapis:

=WYSZUKAJ.PIONOWO(C8;B3:D4;2;0)

wyszuka wartość wprowadzoną w polu C8, w kolumnie B (matrycy B3:D4) i zwróci wartość, która znajduje się dwie kolumny (wartość indeksu to 2) po prawej stronie od znalezionej w kolumnie B wartości. Jeśli więc, w komórce C8 będzie wartość “3 dni”, to funkcja zwróci wartość 5 – czyli wartość z komórki D3.

tabelka z excela

Funkcja WYSZUKAJ.PIONOWO może przeszukiwać dane w kolumnie na dwa sposoby:

  • dokładna wartość – gdy kolejność sortowania oznaczymy jako 0,
  • najbliższa mniejsza wartość – gdy kolejność sortowania oznaczymy jako 1.

 

Ta druga opcja jest przydatna, gdy wyszukujemy w zakresach. W ten sposób nie musimy w matrycy z nakładem wpisywać każdej możliwej wartości, tylko możemy zdefiniować przedziały:

tabela zadruk-nakład

Jeżeli klient wpisze nakład 250 szt., to funkcja znajdzie najbliższą mniejszą wartość w kolumnie C, czyli 201 i dla niej pobierze wartość z kolumn po prawej stronie.

Zagnieżdżanie funkcji

Ostatnim elementem, o którym muszę wspomnieć jest zagnieżdżanie funkcji, czyli umieszczanie funkcji wewnątrz funkcji. Dzięki zagnieżdżaniu możemy tworzyć formuły uwzględniające bardziej złożone warunki, np. “jeżeli klient wybrał zadruk 4+4, to znajdź jego cenę, a jeśli 4+0 to znajdź cenę dla 4+0”.

Tak przykładowo wygląda zagnieżdżenie funkcji WYSZUKAJ.PIONOWO w funkcji JEŻELI:

=JEŻELI(C6="Jednostronny jednokolorowy (1+0)";WYSZUKAJ.PIONOWO(C16;$'Pole-Zadruk'.C3:H5;3;1)

Wyszuka ono wartość nakładu z pola C16 w matrycy i zwróci wartość z kolumny E, jeśli w polu C6 będzie wybrana wartość „Jednostronny jednokolorowy (1+0)”.

Takie warunki są najczęściej wykorzystywane przy obliczeniach, w których w zależności od nakładu lub pola powierzchni zmienia się cena jednostkowa dla kosztu zadruku.

 

Używając kombinacji tylko powyższych dwóch funkcji i zagnieżdżania można zbudować złożone warunki, które wystarczają do stworzenia kalkulatorów dla praktycznie każdego produktu spotykanego w branży poligraficznej. Na nich właśnie oparte są wszystkie przykładowe kalkulatory, które dostarczamy w systemie.

 

Jeśli chcesz porozmawiać z nami o tworzeniu kalkulatorów do swoich produktów, napisz na bok@iwareprint.pl lub przez Ticket Tracking.

 

O autorze
Paweł Dużalski

W iwarePRINT zajmuje się wsparciem technicznym, testowaniem oprogramowania, zarządzaniem projektami związanymi z rozwojem klientów, analizą rynku web-to-print i administrowaniem bloga.

Podziel się wpisem:

KOMENTARZE

komentarzy